Introduction

Conda treats Python the same as any other package, so it’s very easy to manage and update multiple python installations under one computer. For instance, if you want to install different version of python in the same window env but without wipe out the current version of python, you can create and activate a new virtual environment with specific name and install your required version of Python as follows instruction.

Install Python 3.5 under Python 2.7

1. install new python with command:       $ conda create -n py35 python=3.5 anaconda
2. activate the new setup python with command:    $ activate py35
3. deactivate with command: $ deactivate

4. Remove the created env: $ conda remove –name py35 –all

Install Python 2.7 under Python 3.5

1. install new python with command:       $ conda create -n py27 python=2.7 anaconda
2. activate the new setup python with command:    $ activate py27
3. deactivate with command: $ deactivate

Screen Dump of Deinstallation and Installation as below:

C:\User\goldmanau>conda create -n py27 python=2.7 anaconda
Fetching package metadata: ….
Solving package specifications: ………………………….
Package plan for installation in environment C:\Users\goldmanau\AppData\Local\Co
ntinuum\Anaconda3\envs\py27:The following packages will be downloaded:

package                    |            build
—————————|—————–
pandas-0.18.1              |      np111py27_0         7.0 MB  defaults
pickleshare-0.7.2          |           py27_0           9 KB  defaults
pytables-3.2.2             |      np111py27_4         1.5 MB  defaults
scikit-learn-0.17.1        |      np111py27_1         3.5 MB  defaults
sphinx-1.4.1               |           py27_0         1.3 MB  defaults
tornado-4.3                |           py27_1         543 KB  defaults
anaconda-navigator-1.2.1   |           py27_0         1.3 MB  defaults
bokeh-0.11.1               |           py27_0         3.1 MB  defaults
flask-cors-2.1.2           |           py27_0          15 KB  defaults
ipython-4.2.0              |           py27_0         981 KB  defaults
jupyter_client-4.3.0       |           py27_0         138 KB  defaults
nbformat-4.0.1             |           py27_0         155 KB  defaults
odo-0.5.0                  |           py27_0         216 KB  defaults
pyopenssl-0.16.0           |           py27_0          66 KB  defaults
scikit-image-0.12.3        |      np111py27_1        17.6 MB  defaults
sockjs-tornado-1.0.3       |           py27_0          32 KB  defaults
statsmodels-0.6.1          |      np111py27_1         4.6 MB  defaults
dask-0.10.0                |           py27_0         525 KB  defaults
ipykernel-4.3.1            |           py27_0         117 KB  defaults
nbconvert-4.2.0            |           py27_0         354 KB  defaults
jupyter_console-4.1.1      |           py27_0          65 KB  defaults
notebook-4.2.1             |           py27_0         5.2 MB  defaults
qtconsole-4.2.1            |           py27_0         203 KB  defaults
ipywidgets-4.1.1           |           py27_0          98 KB  defaults
nb_anacondacloud-1.1.0     |           py27_0          20 KB  defaults
nb_conda_kernels-1.0.3     |           py27_0          28 KB  defaults
nbpresent-3.0.2            |           py27_0         512 KB  defaults
spyder-2.3.9               |           py27_0         2.1 MB  defaults
jupyter-1.0.0              |           py27_3           3 KB  defaults
nb_conda-1.1.0             |           py27_0          25 KB  defaults
_nb_ext_conf-0.2.0         |           py27_0          912 B  defaults
anaconda-4.1.0             |      np111py27_0          16 KB  defaults
————————————————————
Total:        51.2 MB

The following NEW packages will be INSTALLED:

_nb_ext_conf:       0.2.0-py27_0       defaults
alabaster:          0.7.8-py27_0       defaults
anaconda:           4.1.0-np111py27_0  defaults
anaconda-client:    1.4.0-py27_0       defaults
anaconda-navigator: 1.2.1-py27_0       defaults
argcomplete:        1.0.0-py27_1       defaults
astropy:            1.2.1-np111py27_0  defaults
babel:              2.3.3-py27_0       defaults
backports:          1.0-py27_0         defaults
backports_abc:      0.4-py27_0         defaults
beautifulsoup4:     4.4.1-py27_0       defaults
bitarray:           0.8.1-py27_1       defaults
bokeh:              0.11.1-py27_0      defaults
boto:               2.40.0-py27_0      defaults
bottleneck:         1.0.0-np111py27_1  defaults
bzip2:              1.0.6-vc9_3        defaults [vc9]
cdecimal:           2.3-py27_2         defaults
cffi:               1.6.0-py27_0       defaults
chest:              0.2.3-py27_0       defaults
click:              6.6-py27_0         defaults
cloudpickle:        0.2.1-py27_0       defaults
clyent:             1.2.2-py27_0       defaults
colorama:           0.3.7-py27_0       defaults
comtypes:           1.1.2-py27_0       defaults
configobj:          5.0.6-py27_0       defaults
configparser:       3.5.0b2-py27_1     defaults
console_shortcut:   0.1.1-py27_1       defaults
contextlib2:        0.5.3-py27_0       defaults
cryptography:       1.4-py27_0         defaults
curl:               7.49.0-vc9_0       defaults [vc9]
cycler:             0.10.0-py27_0      defaults
cython:             0.24-py27_0        defaults
cytoolz:            0.8.0-py27_0       defaults
dask:               0.10.0-py27_0      defaults
datashape:          0.5.2-py27_0       defaults
decorator:          4.0.10-py27_0      defaults
dill:               0.2.5-py27_0       defaults
docutils:           0.12-py27_2        defaults
entrypoints:        0.2.2-py27_0       defaults
enum34:             1.1.6-py27_0       defaults
et_xmlfile:         1.0.1-py27_0       defaults
fastcache:          1.0.2-py27_1       defaults
flask:              0.11.1-py27_0      defaults
flask-cors:         2.1.2-py27_0       defaults
freetype:           2.5.5-vc9_1        defaults [vc9]
funcsigs:           1.0.2-py27_0       defaults
functools32:        3.2.3.2-py27_0     defaults
futures:            3.0.5-py27_0       defaults
get_terminal_size:  1.0.0-py27_0       defaults
gevent:             1.1.1-py27_0       defaults
greenlet:           0.4.10-py27_0      defaults
grin:               1.2.1-py27_3       defaults
h5py:               2.6.0-np111py27_0  defaults
hdf5:               1.8.15.1-vc9_4     defaults [vc9]
heapdict:           1.0.0-py27_1       defaults
idna:               2.1-py27_0         defaults
imagesize:          0.7.1-py27_0       defaults
ipaddress:          1.0.16-py27_0      defaults
ipykernel:          4.3.1-py27_0       defaults
ipython:            4.2.0-py27_0       defaults
ipython_genutils:   0.1.0-py27_0       defaults
ipywidgets:         4.1.1-py27_0       defaults
itsdangerous:       0.24-py27_0        defaults
jdcal:              1.2-py27_1         defaults
jedi:               0.9.0-py27_1       defaults
jinja2:             2.8-py27_1         defaults
jpeg:               8d-vc9_0           defaults [vc9]
jsonschema:         2.5.1-py27_0       defaults
jupyter:            1.0.0-py27_3       defaults
jupyter_client:     4.3.0-py27_0       defaults
jupyter_console:    4.1.1-py27_0       defaults
jupyter_core:       4.1.0-py27_0       defaults
libpng:             1.6.22-vc9_0       defaults [vc9]
libtiff:            4.0.6-vc9_2        defaults [vc9]
llvmlite:           0.11.0-py27_0      defaults
locket:             0.2.0-py27_1       defaults
lxml:               3.6.0-py27_0       defaults
markupsafe:         0.23-py27_2        defaults
matplotlib:         1.5.1-np111py27_0  defaults
menuinst:           1.4.1-py27_0       defaults
mistune:            0.7.2-py27_0       defaults
mkl:                11.3.3-1           defaults
mkl-service:        1.1.2-py27_2       defaults
mpmath:             0.19-py27_1        defaults
multipledispatch:   0.4.8-py27_0       defaults
nb_anacondacloud:   1.1.0-py27_0       defaults
nb_conda:           1.1.0-py27_0       defaults
nb_conda_kernels:   1.0.3-py27_0       defaults
nbconvert:          4.2.0-py27_0       defaults
nbformat:           4.0.1-py27_0       defaults
nbpresent:          3.0.2-py27_0       defaults
networkx:           1.11-py27_0        defaults
nltk:               3.2.1-py27_0       defaults
nose:               1.3.7-py27_1       defaults
notebook:           4.2.1-py27_0       defaults
numba:              0.26.0-np111py27_0 defaults
numexpr:            2.6.0-np111py27_0  defaults
numpy:              1.11.0-py27_2      defaults
odo:                0.5.0-py27_0       defaults
openpyxl:           2.3.2-py27_0       defaults
openssl:            1.0.2h-vc9_0       defaults [vc9]
pandas:             0.18.1-np111py27_0 defaults
partd:              0.3.4-py27_0       defaults
path.py:            8.2.1-py27_0       defaults
pathlib2:           2.1.0-py27_0       defaults
patsy:              0.4.1-py27_0       defaults
pep8:               1.7.0-py27_0       defaults
pickleshare:        0.7.2-py27_0       defaults
pillow:             3.2.0-py27_1       defaults
pip:                8.1.2-py27_0       defaults
ply:                3.8-py27_0         defaults
psutil:             4.3.0-py27_0       defaults
py:                 1.4.31-py27_0      defaults
pyasn1:             0.1.9-py27_0       defaults
pycosat:            0.6.1-py27_1       defaults
pycparser:          2.14-py27_1        defaults
pycrypto:           2.6.1-py27_4       defaults
pycurl:             7.43.0-py27_0      defaults
pyflakes:           1.2.3-py27_0       defaults
pygments:           2.1.3-py27_0       defaults
pyopenssl:          0.16.0-py27_0      defaults
pyparsing:          2.1.4-py27_0       defaults
pyqt:               4.11.4-py27_6      defaults
pyreadline:         2.1-py27_0         defaults
pytables:           3.2.2-np111py27_4  defaults
pytest:             2.9.2-py27_0       defaults
python:             2.7.11-5           defaults
python-dateutil:    2.5.3-py27_0       defaults
pytz:               2016.4-py27_0      defaults
pywin32:            220-py27_1         defaults
pyyaml:             3.11-py27_4        defaults
pyzmq:              15.2.0-py27_0      defaults
qt:                 4.8.7-vc9_8        defaults [vc9]
qtconsole:          4.2.1-py27_0       defaults
qtpy:               1.0.2-py27_0       defaults
requests:           2.10.0-py27_0      defaults
rope:               0.9.4-py27_1       defaults
ruamel_yaml:        0.11.7-py27_0      defaults
scikit-image:       0.12.3-np111py27_1 defaults
scikit-learn:       0.17.1-np111py27_1 defaults
scipy:              0.17.1-np111py27_1 defaults
setuptools:         23.0.0-py27_0      defaults
simplegeneric:      0.8.1-py27_1       defaults
singledispatch:     3.4.0.3-py27_0     defaults
sip:                4.16.9-py27_2      defaults
six:                1.10.0-py27_0      defaults
snowballstemmer:    1.2.1-py27_0       defaults
sockjs-tornado:     1.0.3-py27_0       defaults
sphinx:             1.4.1-py27_0       defaults
sphinx_rtd_theme:   0.1.9-py27_0       defaults
spyder:             2.3.9-py27_0       defaults
sqlalchemy:         1.0.13-py27_0      defaults
ssl_match_hostname: 3.4.0.2-py27_1     defaults
statsmodels:        0.6.1-np111py27_1  defaults
sympy:              1.0-py27_0         defaults
tk:                 8.5.18-vc9_0       defaults [vc9]
toolz:              0.8.0-py27_0       defaults
tornado:            4.3-py27_1         defaults
traitlets:          4.2.1-py27_0       defaults
unicodecsv:         0.14.1-py27_0      defaults
vs2008_runtime:     9.00.30729.1-2     defaults
werkzeug:           0.11.10-py27_0     defaults
wheel:              0.29.0-py27_0      defaults
xlrd:               1.0.0-py27_0       defaults
xlsxwriter:         0.9.2-py27_0       defaults
xlwings:            0.7.2-py27_0       defaults
xlwt:               1.1.2-py27_0       defaults
zlib:               1.2.8-vc9_3        defaults [vc9]

Proceed ([y]/n)? y

Fetching packages …
pandas-0.18.1- 100% |###############################| Time: 0:01:17  94.50 kB/s
pickleshare-0. 100% |###############################| Time: 0:00:00   1.48 MB/s
pytables-3.2.2 100% |###############################| Time: 0:00:15 101.08 kB/s
scikit-learn-0 100% |###############################| Time: 0:00:35 103.10 kB/s
sphinx-1.4.1-p 100% |###############################| Time: 0:00:15  88.76 kB/s
tornado-4.3-py 100% |###############################| Time: 0:00:04 112.43 kB/s
anaconda-navig 100% |###############################| Time: 0:00:13 103.67 kB/s
bokeh-0.11.1-p 100% |###############################| Time: 0:00:38  83.75 kB/s
flask-cors-2.1 100% |###############################| Time: 0:00:00  33.06 kB/s
ipython-4.2.0- 100% |###############################| Time: 0:00:09 106.52 kB/s
jupyter_client 100% |###############################| Time: 0:00:02  61.09 kB/s
nbformat-4.0.1 100% |###############################| Time: 0:00:01  89.78 kB/s
odo-0.5.0-py27 100% |###############################| Time: 0:00:02  76.72 kB/s
pyopenssl-0.16 100% |###############################| Time: 0:00:01  55.44 kB/s
scikit-image-0 100% |###############################| Time: 0:03:35  85.86 kB/s
sockjs-tornado 100% |###############################| Time: 0:00:00  66.93 kB/s
statsmodels-0. 100% |###############################| Time: 0:00:51  92.79 kB/s
dask-0.10.0-py 100% |###############################| Time: 0:00:06  84.35 kB/s
ipykernel-4.3. 100% |###############################| Time: 0:00:01  66.01 kB/s
nbconvert-4.2. 100% |###############################| Time: 0:00:05  68.28 kB/s
jupyter_consol 100% |###############################| Time: 0:00:01  45.59 kB/s
notebook-4.2.1 100% |###############################| Time: 0:00:53 100.82 kB/s
qtconsole-4.2. 100% |###############################| Time: 0:00:02  72.55 kB/s
ipywidgets-4.1 100% |###############################| Time: 0:00:01  86.14 kB/s
nb_anacondaclo 100% |###############################| Time: 0:00:00  37.88 kB/s
nb_conda_kerne 100% |###############################| Time: 0:00:00  67.10 kB/s
nbpresent-3.0. 100% |###############################| Time: 0:00:04 112.47 kB/s
spyder-2.3.9-p 100% |###############################| Time: 0:00:26  81.65 kB/s
jupyter-1.0.0- 100% |###############################| Time: 0:00:00   0.00  B/s
nb_conda-1.1.0 100% |###############################| Time: 0:00:00  61.82 kB/s
_nb_ext_conf-0 100% |###############################| Time: 0:00:00   0.00  B/s
anaconda-4.1.0 100% |###############################| Time: 0:00:00  40.15 kB/s
Extracting packages …
[      COMPLETE      ]|##################################################| 100%
Linking packages …
1 file(s) copied.####################                            |  44%
[      COMPLETE      ]|##################################################| 100%
#
# To activate this environment, use:
# > activate py27

C:\Users\goldmanau>conda remove  –name py27 –all
Fetching package metadata: ….Package plan for package removal in environment C:\Users\goldmanau\AppData\Local
\Continuum\Anaconda3\envs\py27:

The following packages will be REMOVED:

menuinst: 1.4.1-py27_0 defaults

Proceed ([y]/n)? y

 

Reference Doc Link

http://conda.pydata.org/docs/py2or3.html

Leave a Reply

Your email address will not be published.

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>